PDA

View Full Version : Push Button 4wd Operation, Problems, Troubleshooting and Diagnostic Codes



Tink
10-26-07, 07:27 AM
The Main 4wd Components:
TCCM - Transfer Case Control Module - Located behind the glove box. This is the electronic ‘brains’ behind the shifting.
Switch – The push button switch in the dash - driver input/indicator.
Encoder Motor– Located on the transfer case – This is what actually shifts the transfer case, and tells the TCCM what position it is in.
Vacuum Switch – Also located on the transfer case – This is what sends vacuum to the vacuum actuator (see below) when the transfer care is in 4HI or 4LO.
Vacuum Actuator – Located under the battery tray – This is what engages or disengages the front driveshaft.
Front Axle Switch – Located on the front axle – This is what tells the TCCM when the front axle is engaged.

There are 2 types of shifts - mode shifts, and range shifts. A mode shift would be from 2HI to 4HI, and vise versa. A range shift would be in and out of 4LO. You can Mode shift any time when moving, but must be stopped in neutral to do a range shift.

Normal Operation: When the switch is pressed, the indicator light flashes, and the TCCM tells the encoder motor to move from its current position to the desired position. When the transfer case enters 4HI, it engages the vacuum switch to engage the front axle. The axle switch then tells the TCCM that it's engaged. Then the 4wd indicator light will come on. The transfer case has 3 positions. 2HI, 4HI, and 4LO, in that order. T he encoder motor senses which position it is in, and tells the TCCM definitively where the transfer case is.


Common problems:
Switch failure: Nothing works. Pushing either end causes NOTHING to actuate (No sound from dash or transfer case)

Encoder failure: Transfer case will not enter 4HI, but will enter 4LO. This is because the computer doesn't know exactly what position the case is in, so it just moves to either extreme (2HI or 4LO).

Vacuum actuator failure: Rubber diaphragm breaks. The transfer case changes position, but the front axle never engages. Takes an extended time for the indicator lights to come on.

Secondary problem list:

4wd does not engage:
Vacuum hoses deteriorated
Engine vacuum insufficient
Front axle actuator cable is kinked or seized
Faulty front axle vacuum actuator
Faulty transfer case vacuum switch
Faulty 4wd indicator lamp
Blown TCCM fuse
Bad electrical connections
Faulty switch
Faulty encoder motor
Faulty TCCM Faulty transfer case
Faulty front axle


4wd will not disengage:
Faulty wiring
Faulty lamp
Transfer case vacuum switch plugged or faulty
Vacuum lines pinched
Transfer case vent filter plugged
Actuator cable kinked or damaged
Faulty switch
Faulty encoder motor
Faulty TCCM
Faulty front axle


4wd disengages under load:
Insufficient vacuum
Vacuum system not venting properly

Transfer case noisy in all modes:
Low transfer case lube level
Internal transfer case problem

Noisy in 4LO:
Transfer case not completely engaged; disengage and re-engage it
Internal transfer case problem

Leaking from Transfer case vent:
Transfer case overfilled – often caused by the seal between the transfer case and transmission going bad.

Leaks at output shafts:
Transfer case overfilled
Vent hose plugged or kinked
Seals damaged

Tink
10-26-07, 07:31 AM
How to obtain diagnostic trouble codes:


For OBDI vehicles with the push button above the light switches:

To read the codes for the push button shift transfer case 4wd system, install a jumper wire from terminals "J" and "A" on the ALDL (12 pin connector under the driver's side dash) - A is the top right pin and J is the third from the left on the bottom.

http://www.vanforum.net/Extern/Technik/Images/Bilder/Connector-1.jpg


Then the turn the ignition to run (DO NOT START). The 4wd indicator lights will self test, then go out. Then if any codes are stored they will flash. If more than one is stored, they will alternate flashes... for example:

flash - pause - flash flash flash - pause - flash - pause -flash flash flash
Would indicate codes 1 and 3...

The error codes are:
1 - RAM Standby Power Fault
2 - Encoder Fault
3 - TCCM Motor circuit
4 - Ram/Rom failure

1- Ram Standby power fault: Possible open connection or short in the TCCM fuse circuit. However, this code is often considered normal and may be caused by clearing the codes.

2 - Encoder fault: Every time the t-case position moves, the TCCM checks the encoder’s readings during the shift. If something isn't right, it will increment an error counter by 4. A successful reading decreases the counter by 1. If the counter reaches 32, the TCCM determines the encoder faulty, and bypasses 4hi. Check for loose wires and excessive dirt/moisture near all connectors.

3 – TCCM (Transfer Case Control Module) motor circuit: Basically, every time the TCCM is powered up, it tests the encoder motor. If something isn't right, it will trip the code 3.
Possible causes
1. Open or shorted circuit between encoder motor and TCCM.
2. Short/open connection in the motor itself
3. Malfunctioning motor relay
(this can cause the indicator lights to flash all the time (normal driving). If this happens, it must be fixed IMEDIATELY. It can cause encoder motor failure even when the ignition is off.

4 - Ram/Rom failure: Internal software failure. Pull the TCCM fuse for 3 mins. Then replace it, and cycle the ignition from off to run 5 times. Then re-check the codes. If code 4 still is present, then the TCCM must be replaced.


For OBD-II vehicles with push button between the instrument panel and the radio/HVAC control stack:


The diagnostic trouble codes are displayed on the three transfer case shift select buttons located on the instrument panel. When the connector pin 13 on the data link cable is grounded, and the ignition switch has been OFF for at least five seconds prior to positioning the ignition switch to run the shift select buttons will blink various times together in order to indicate a diagnostic trouble code from 1 to 4.


Position the ignition switch to OFF. Ensure the ignition switch is positioned to OFF for at least 6 seconds. Connect pin 13 on the data link cable to a vehicle ground source. The data link connector is located in the cab under the instrument panel on the driver’s side. Position the ignition switch to RUN. Note the shift select buttons for blinking codes.
If the shift select buttons all blink one time and stop, and do not continue to blink, no fault codes are stored in the TCCM. The transfer case shift select buttons will blink in order to identify any stored trouble code. If only one code is stored in the TCCM memory, that code will blink repeatedly with a three second delay between blinking sequences. If more than one code is stored, the first code will blink once, then after a three seconds delay, the next code will blink. This sequence will continue until pin 13 is no longer grounded.

When reading the diagnostic trouble codes, the number of shift select buttons blinks will indicate the code number.


The error codes are:
1 - When the ignition switch is positioned to RUN the TCCM test to determine if RAM standby Power (maintained battery power) to the TCCM was lost since the ignition was last turned OFF. When power is interrupted on pin C6 of the TCCM, the TCCM stores a loss of RAM standby power.
2 - During electronic shifting, the TCCM check the motor/encoder for normal operation. If the motor/encoder does not function correctly enough times, the TCCM stores a motor/encoder failure DTC 2.
3 - The TCCM performs a test each time the electronic-shift motor is turned ON or OFF. If the motor does not function properly the TCCM stores a motor circuit failure DTC 3, and the shift select buttons blink in order to inform the driver of a problem.
4 - Each time the ignition is turned ON, the TCCM tests the memory, the program, and the internal system in order to ensure that the TCCM is operating properly. If the TCCM detects a fault within the TCCM, the TCCM stores a RAM/ROM memory failure (DTC) 4.

Tink
10-26-07, 07:36 AM
How to fix common push button 4wd problems:

If you have codes 2 or 3 check all the encoder motor connections at the transfer case, if those check out OK, you will probably need a new encoder motor.
If you have code 4, replace the TCCM.

Make sure all connections are good and no corrosion, and then it's either an encoder or TCCM.

How to replace the TCCM

The TCCM is located behind the glove box, and is accessed from underneath the dash. In order to get to it, the kick panel and black cover need to be removed. Then a 1/4" screw holds the TCCM and ECM in the dash. The middle computer is the ECM, the one on the backside is the TCCM, and on the front is the small ABS computer. Simply loosen the two 10mm nuts on each side, and they will separate.

How to fix the encoder motor

Cheap way - To clear the codes and reset the computer, pull the 5 amp TCCM fuse, located at the bottom of the fuse box. Wait at least a half hour, and then replace the fuse. Turn the ignition key to run, wait for the 4x4 lights to blink, and then turn off. Repeat 5 times, and then start the truck.

Reasonably priced way - http://www.northernautoparts.com (http://www.northernautoparts.com/). The part costs around $140 with a 1 year warranty and $38 core refund when you send the old one back.

Expensive way - buy a brand new one from GM for over $300.

How to install the encoder motor

Lucky way – The only thing that needs to be removed is the encoder motor itself. Tools needed are a 10mm hand wrench and an 8mm and 10mm socket wrench. The 10mm socket will work on the upper and lower bolts, while the regular wrench is needed for the middle bolt. (Tight squeeze!). The 8mm socket is for the electric plug. Remove the bolts and connector, then, just pull and wiggle it out of the truck. Install in reverse order.

Unlucky way - This means the encoder motor did not just wiggle out. Now the front drive shaft will have to be removed at the transfer case. Then, a yolk puller is needed in order to remove the yolk from the transfer case. Once this is done, go back to the directions in lucky way.


How to change your push-button to manual shift:
http://www.zr2usa.com/mboard/index.php?showtopic=11695



Information compiled from Chilton’s manual, ZR2USA.com and s10extremist.org.

warp9pnt9
06-17-08, 12:05 PM
SUPERB write up, thank you!

pluto
04-25-09, 01:35 PM
i have a code CO 308 motor A/B current low. this is on a 2000 chevy S-10 blazer with the 2 HI - 4 HI - 4 LOW - AUTO 4 on the push buttons on the dash.


help?

pluto
05-09-09, 12:40 AM
ok this is what i found out. i removed the kick panel on the passenger side and found the TCCM. i used an ice scraper to bang on the TCCM and the buttons on the dash for the 4WD worked. i even heard the clicking sound from the TCCM.



but this did not fix the problem. everything worked good for a short time. the encoder motor shifted the select drive options and 4WD worked. now this leads me to believe that the problem is in the TCCM. the clicking sound from the TCCM sounds like a relay switch. the TCCM has metal ears that can be bent up to remove the cover of the TCCM. i have not done this yet.


might there be a relay switch inside the TCCM that could be replaced?

pluto
05-10-09, 03:29 PM
well, i took out the TCCM and opened it up by bending the metal ears up. this is nothing but some kind of circuit board.



and it does have 2 relays on it that are soldered to the board. so anyhow, the orange block that is soldered to the board had some green corrosion on #1 PIN. i scraped it off the best i could. put it all back together and no luck.


what i think is going on is this:


the orange block that is soldered to the board did have some green corrosion on #1 PIN. the PIN itself goes through the orange block and is soldered to the circuit board. in fact, all the PINS that go through the orange block are soldered into the circuit board. so what im thinking is this.



you can only clean the green corrosion as far as you can reach on the PIN itself. there still might be green corrosion on the part of the PIN that is embedded in the orange block. what you do next is up to you.

pluto
10-18-09, 11:49 AM
ok so i sent the TCCM to a place in Tennessee that rebuilds TCCM's and other components. when i got the thing back, i plugged it in and still nothing worked. so i took the Blazer to a mechanic and they pulled a TCCM out of a like year Blazer and guess what? everything worked!


so i got hold of ECU.com and explained to them whats going on. they told me to send the TCCM back and they would check to see if they missed something. well im thinking, "yeah. apparently you did miss something." so anyhow, im waiting for the TCCM to come back and i'll keep you all updated on this.

chargedextreme
11-14-09, 05:11 PM
where is the Vacuum actuator located

Tink
11-14-09, 05:44 PM
It is under the battery tray.

chargedextreme
11-14-09, 05:49 PM
would that cause it to not come out of 4lo?

Tink
11-15-09, 09:44 AM
Is this push button or floor shift?

warp9pnt9
11-15-09, 01:31 PM
My 3-push button 97 Blazer ZR2 wouldn't engage 4WD HI or LO. Problem was suspected vacuum actuator, under battery tray. However, that was fine. Actual problem was the shift fork actuator, on the front differential. There are two actuators involved for my vehicle. But the S10 platform varies a LOT.

Slacker1357
11-15-09, 02:10 PM
as far as how to remove the front shaft.

All I did was remove the bolts holding the U-joint, drop the front of the shaft, then take a piece of wood and a hammer, and smack the back of the front shaft out of the T-case. Real simple...
You may need some WD-40 to loosen up the U-joint from the front yolk.
Be sure not to let those caps fall off the U-joint!

chargedextreme
11-16-09, 02:57 AM
mine is a 1994 jimmy with push button

chargedextreme
11-16-09, 01:16 PM
anyone have any ideas

Tink
11-16-09, 04:23 PM
mine is a 1994 jimmy with push button

Most common problem would be the encoder motor... but, I'd recommend checking the codes following the instructions in the first post.

pluto
12-06-09, 04:15 PM
UPDATE


Winter comes early in New Hampshire. I bought a new TCCM at Walier Chevrolet for $330.00.


Plugged it in and now I have the 4-wheel drive working.


autoecu.com is giving me a hard time about my $149.00 refund. Is there any lawyers registered here?

Heavy Chevy
12-25-09, 02:03 PM
Do theese steps apply to my 2003 ZR2????????

pluto
12-26-09, 02:17 PM
its probably the damn TCCM

chevybrat
12-26-09, 04:47 PM
Have no idea if this helps Dave, but my truck kicked itself into 4lo in 2007 I believe it was as I was driving down a side street and I had to have the 4x4 switch replaced.

I have a 2001 ZR2 push button 4x4.

Heavy Chevy
12-27-09, 11:40 AM
thank you,and I got my part on order.I got to the bottom of the problem yasterday.Chevy trucks in the past have never given me such a head ache.Like I said it's my first 4x4 S-10.

Heavy Chevy
12-28-09, 06:52 PM
well I got the four wheel drive back,one new transfer case motor(encoder)and about one in a half hours of labor.Did have to remove the front axle but it was'nt bad.Feelin much better.Thanks again everyone!!!!!!!!!!!!!!!!

Tink
12-29-09, 10:21 AM
Glad you got it working again!

Heavy Chevy
01-02-10, 07:08 PM
thanks alot Tink,I really like this write up you got here.Its real helpfull.:D

j894
02-07-10, 03:46 PM
I hate to kick up an old thread again but if youre having problems going into 4high (which worked recently) but you have 4 low and 2high, definitely try unhooked your battery for a little while first to clear the ram/stored codes.

....because my truck was sitting for a month at a body shop and when I got it back 4high wasn't working. It would blink the lights for 4x4 then go back to 2high. Then the 4high buttons stopped working and did nothing.

4low worked after blinking some and 2 high worked... I tried pulling the fuses for "4x4" and "ATC" thinking it would reset everything but I had no luck... .right before I started unbolting the encoder motor I unhooked the battery for a few minutes and tried it again.... everything now works..

Apparently, the tccm has a failsafe or something that will disable 4high and only go to 2high or 4low if there was initially a problem. I wonder if the motor wasnt able to shift into the 4high position at 1st... and shifting into 4low and back to 2wd a few times unjammed it? then unhooking the battery reset the tccm..

so, if ur having the problem... shift to 4low and back a few times, then hook the batt. for a little while and try again. ....

At leas this was my experience.
Hope this helps someone fix their problem....

'94 Benson
08-26-10, 05:39 PM
Does any one happen to know where to get a wiring diagram for the4wd system? My 1992 blazer with the rocker switch when we gotthe truck it had the switch unpluged and taped up when we pluged it in it blinked for a few seconds then never lit up again. any ideas?

erik1986
10-23-10, 07:48 AM
Hello,

My 98 Blazer is making me crazy.
Since I bought it I have spent more than 4 k in repairs, radiator, waterpump, heatercore, all engine gaskets and more on...

And now the freaking 4x4 is not working!

I have read on this great forum and tried all of the simple fixes and I am stuck. The reseting by unplugging the battery doesen´t work, the fault comes back after 2 tries to shift to either 4Hi or 4Lo

When I push the 4Hi or 4Lo I hear the TCCM clicking twice, no more.
Not the regular shifting sound from underneath.
Today I removed the battery to look at the actuator and it was in as if there where vacum on it. I removed the vacumhose and started the engine and there where vacum but the panel lights 2Hi...

What is wrong?

Tink
10-24-10, 09:02 AM
So without vacuum to the actuator it is still engaging the axle? Sounds like the cable may be seized...

erik1986
10-24-10, 01:21 PM
Do the cable run down to the front axle or the gearbox?
And should there really be vacum applied when 2Hi mode is on...

Heavy Chevy
12-16-10, 07:21 PM
I hate to kick up an old thread again but if youre having problems going into 4high (which worked recently) but you have 4 low and 2high, definitely try unhooked your battery for a little while first to clear the ram/stored codes.

....because my truck was sitting for a month at a body shop and when I got it back 4high wasn't working. It would blink the lights for 4x4 then go back to 2high. Then the 4high buttons stopped working and did nothing.

4low worked after blinking some and 2 high worked... I tried pulling the fuses for "4x4" and "ATC" thinking it would reset everything but I had no luck... .right before I started unbolting the encoder motor I unhooked the battery for a few minutes and tried it again.... everything now works..

Apparently, the tccm has a failsafe or something that will disable 4high and only go to 2high or 4low if there was initially a problem. I wonder if the motor wasnt able to shift into the 4high position at 1st... and shifting into 4low and back to 2wd a few times unjammed it? then unhooking the battery reset the tccm..

so, if ur having the problem... shift to 4low and back a few times, then hook the batt. for a little while and try again. ....

At leas this was my experience.
Hope this helps someone fix their problem....

yes,I did this and turned the key to the run position,waited for the 4x4 lights to blink and then repeated 5 times!No go for me.Needed new encoder!
but here it is a year later and have another 4x4 problem so.... i disconnected the negative battery cable waited 30 minutes and did the said above!
seemed to work this time!
I did use the 4x4 this summer more than a few times so,with this said whats up with the four wheel drive in the cold weather!Had no problems what so ever this summer in the mud!:confused:

spideyjected
12-16-10, 07:58 PM
hmmm, idk. Mine works great in the cold... (o; I guess I'd assume it's a bad connection somewhere. For example, my heat only works "without assistance" when it's above 35 degrees farenheit, lol...

Heavy Chevy
12-18-10, 01:47 PM
well it was working again,checked the codes today and it blinked two times!Time for another encoder i guess!I got down and took off the skid plate so i could access the encoder and checked out the electrical connections.Everything appears to be ok!

Must of gotten a bad encoder motor i guess!Advance did not have them and had to order it from someone else(last year)They say warranty is up!:mad:

Guess i will order one from the link Tink put one her write up!Gm wants way to much but that may be a good safe bet!

Any other suggestions as to ware to get an encoder motor would be appreciated!

DokiZen6x
12-16-11, 03:52 PM
I have a 97 gmc sonoma highlander that I just bought a few months ago. Replaced pass side half shaft after bringing the frame strait again (long story). New wheel bearing and ball joints over there, along with alignment.

Sometimes at highway speeds, it makes a nasty wherrring noise that is only canceled when I engage the 4 hi button. Is it my hub locks or something else?

neo71665
12-16-11, 06:19 PM
When is the last time you checked the t-case fluid?

DokiZen6x
12-16-11, 09:36 PM
Trams fluid was checked recently, the cases not seance I bought it. The noise is from the pass front wheel.

chaddaddy
12-18-11, 07:38 AM
http://www.s10planet.com/forum/images/icons/icon1.png need help troubleshooting 4x4 and ABS systems
I have just recently purchased a 1993 Chevy S10 4x4 Blazer,with the 4.3 "W" code motor, 4L60 transmission and push button four wheel drive. I have tried to use the forums on this site to diagnose my problems, but have not had any luck where the 4wd and ABS are concerned. any help you guys can offer will be greatly appreciated.

4x4 system: when i first start the blazer both the green and orange lights come on on the rocker switch for about 1 sec, then go off. Pushing the rocker either way gets no response or attempt to lock in the transfer case. I put in a jumper between pins A and J on the ALDL, then turned my ign. sw. to the run position to get any codes stored for it, but that does nothing that i can tell. And that's where i'm stuck at on that system.

The ABS i'm still working on. I'm trying to hunt down the cause for that system to be throwing a 42 (control Valves). as i said any input is greatly appreciated.

Junksterr
12-28-11, 11:35 AM
How do I know what transfer case I have? I want to do the mmanual shifter mod but he stated that it can't be done on a 233 or something like that

2000 zr2 blazer push button 4wd with auto 4wd

Tink
12-28-11, 04:49 PM
I think the auto 4x4 cases are NP243s. And no, you cannot convert them to floor shift.

Junksterr
12-28-11, 06:05 PM
Tink is there a specific reason they cannot be converted over? Location of shifter linkage or is it just not able to be done?

Jongo88
12-28-11, 06:12 PM
Because they use an electric motor to shift...

Junksterr
12-28-11, 06:35 PM
Ahhh is the motor located inside the tcase? Just trying to feel this out my 4wd isn't working and its seeming like an encoder motor I gotta do the thing to check the codes but I know it wont lock hi or lo but the rear axles will lock in.

Tink
12-29-11, 09:51 AM
When you push the auto 4wd button the front end is engaged. It just isn't engaged in the transfer case. Only the back wheels have power. When the vehicle detects slip (determined by wheel sensors), the transfer case engages. I'm pretty sure this transfer case is set-up differently than the NP233 and I know that it is larger (I had one on my 2000 BlaZeR2, and I have regular push button on my 92 Blazer)... where exactly the motor is that engages based on slippage, I don't know. I had trouble with the 4wd on my BlazeR2... sometimes it would work, sometimes the lights just blinked.

Junksterr
12-29-11, 12:59 PM
thats the problem im having.... I thought maybe it was locking and would just blink but nope.... front axles not engaged I was stucked.

The auto 4wd will just blink and i knew it would auto lock whenever it lost traction, but i have never used it... Im guessing 4wd has never worked cause the lights have always jsut blinked, but i thought they were locking in.

I tried looking up a custom made manual shift and found one to no avail, I did see where these tcases were swapped out for 233's and 231's but then people were questioning the integrity of the tcase whether it would hold up or not.

SleeperSS
12-30-11, 10:02 AM
Here's my problem...my folks have a 2000 S10 TrailBlazer. The push button switch will intermittently light up and blink...all of the buttons at the same time. The "Service 4WD" light comes on at the same time. My dad says the 4wd functions all seem to work. He replaced the switch but the problem remains.

5 minutes passes...

I just looked at the TCCM on Rockauto.com. They had a video and it looks like that may be the problem. Can anyone confirm??

Tink
12-31-11, 10:15 AM
With my 2000 BlaZeR2, it was a bad vaccum actuator or something to do with that... I am almost sure about this, because when I wheeled, I would loose 4wd after going through high water. Everything electrical always sounded like it engaged/worked.

FMC627
01-16-12, 01:43 PM
Hey guys, need some help.
I bought a 2004 s10ZR2. The four wheel drive does not work. The switch on the dash does not light up and the truck will not go into four wheel drive. The previous owner said they had the transmission rebuilt and the 4x4 has not worked since. The scanner says their is no communication with the transfer case. It does get codes from other components. The first thing I did was replace the TCCM, no luck. I saw something that said I should have power to the #6 pin coming into the TCCM. I dont have power. Found the relay block under the dash and all seems to be ok there. All fuses are ok also. I am at a loss, I don't know what to do next. Should I replace the encoder motor, actuator, and dash switch? That would cost a lot wouldn't it? Any help would really be appreciated!!!

Michael Miner
03-13-12, 10:25 PM
Here's one one for ya.

My 95 zr2 has push button 4wd. 2hi works but no light up. 4hi dosent blink when pushed, it just lights straight up, you can hear what sounds like an electric motor working and the clunking of the t case. Drop it in to drive, feels like it torqueier than normal. But in the dirt you hammer it and only the rear end spins. Push 4hi and no lights, and no sounds. Put it in to drive, and it feels like it stayed in 4hi and the 4hi back light stays on, dosent blink or any thing. What gives.

Edit; its also leaking out of the t case breather tube. The tube that's attached to the trans dip stick tube?

Jongo88
03-13-12, 10:46 PM
Sounds like your transfercase it overflowing... When that happens your seal between the transmission and transfercase is bad...
That lets the transmission fluid leak from the transmission into the transfercase...
The other thing that could be bad is the switch is bad letting the fluid leak up the breather tube.
Just pull the fill plug on the transfercase and if fluid pores out you have a bad seal...

Michael Miner
03-14-12, 06:55 AM
How bad is this seal to replace? That would make sence considering the trans is slowly getting lower and lower on fluid.

Jongo88
03-14-12, 11:47 AM
This will show how to remove the transfercase and you can see the input seal you need to replace...



http://www.s10planet.com/forum/showthread.php?t=14238&highlight=transfer+case+seal (http://www.s10planet.com/forum/showthread.php?t=14238&highlight=transfer+case+seal)

Michael Miner
03-14-12, 02:37 PM
that dosent seem to hard. just time consuming. but such is this truck. what seems easy is difficult due to rust.

Jongo88
03-14-12, 02:45 PM
I have done this and it's not to bad just hard to bench press back up in there line it up and start the first bolt... I did it in my driveway by myself.

Michael Miner
03-14-12, 03:09 PM
ok, easy enough. i think the muscle part shouldent be to bad, im a pretty strong guy; 6 foot 1 and 216lbs

970joe
01-23-13, 11:48 PM
I have a 95 S10 pick up with the push button 4 wheel drive. While driving in 2HI and decelerating I start hearing a whiring noise coming from the transfer case. If I hit the 4HI selector button it will go away but then after a few miles it will come back again and I have to hit the 4HI button again. My 4 wheel drive system functions in 2HI 4Hi and even 4LOW, I have checked the front cable and the vacumm actuator and they are both functioning properly. Has anyone ever run into this before? I have read that it could be the encoder motor but from it sounds like if that was bad i shouldnt be able to have 4HI function.

Tikko
02-09-13, 12:20 PM
I have a 93 s-10 blazer, 4wd was working fine, it sat for about a month, now the switch does't light up, no clicking from tccm or transfer case. I pulled the tccm fuse waited and replaced it and the 4wd worked fine for a few hours, the nothing again, I have tried resetting the tccm by pulling the fuse, waiting and turning the ignition 5 times with no luck. In the original post it says if no lights light up on the switch, it's a switch problem, however, when I ran the diag by jumping the pins, I got 2 flashes. Does that mean it is the encoder, or since the switch doesn't light up, could it be the switch, or does the encoder not working make the lights on the switch not light up? The lights light up when starting the truck, so I know they work.

corkumg
12-16-13, 01:38 PM
I have the 4x4 3 push button twice now I have had to take the negative battery terminal off to reset the codes in the tccm. what was happening was my 2hi would work and then when I went to 4 hi it wouldnt then I would try 4 low and it would engage. SO the only simple way I could resolve this issue is to reset the modual via taking the negative off for a while. I had my encoder motor replaced last year along with my tccm rewired. due to a corroded harness. Just an annoying 4x4 system when they went to push button they really made a simple thing complicated.

corkumg
12-16-13, 01:44 PM
possibly an issue with the encoder again. So im assuming once the modual gets a fault code it wont allow me to try it again. When I reset it it goes into 4x4 High. leads me to believe something is shorted or something is on its way out. But isnt quite there yet probably the damn encoder motor again.

cupofcoffey
11-11-14, 08:33 PM
hope someone still goes on this thread, but my 2000 s10 was stuck in 4lo and wont even try to come out of it. i checked for codes on the tccm from this forum and i have cods 1 and 3. i have taken off the encoder motor and tested it. the average energy reading is about 5.1-2 volts.