Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: One Peice Driveshaft

  1. #1
    Join Date
    Feb 2007
    Location
    Tallahassee
    Age
    38
    Posts
    22,743
    Rep Power
    591483

    One Peice Driveshaft

    A very common issue with extended cab S-series is the 2 piece driveshaft. The support bearings go bad, theres alignment issues on ZQ8 models (and other lowered rides) and the double cardan joint is a problem.
    Getting one custom made can be hard to find and also pricey since its a custom build.

    Well, now InlandEmpire is making a replacement one-peice shaft ready to install.
    IDK if you have choices like their regular custom made units, but they do have Steel, Aluminum and Composite made ones.

    You will have to call for pricing. Here is their link : http://www.iedls.com/home.html
    2003 S-10 ZQ8 - 262/M5 1986 Pontiac Trans Am - 355/A4

  2. #2
    Join Date
    Nov 2007
    Location
    Mid Missouri
    Age
    26
    Posts
    10,288
    Rep Power
    386452

    Re: One Peice Driveshaft

    awesome thanks mike
    1988 S10 Reg cab shortbed 2.5 Iron duke m5
    2002 Camaro z28 T-56 blacked out

  3. #3
    Join Date
    Feb 2005
    Location
    Lexington, KY
    Age
    30
    Posts
    4,071
    Rep Power
    10

    Re: One Peice Driveshaft

    Where were they at when I had to get a new driveshaft.... damn
    Want S10Planet stickers or an EGR Limiter? Get it in the store... S10Planet Store

    For some of the best all natural angus beef and jerky check out the guys at Nebraska Star Beef.

  4. #4
    Join Date
    Jun 2006
    Location
    Sackville, NB, Canada
    Age
    37
    Posts
    5,071
    Rep Power
    481068

    Re: One Peice Driveshaft

    Good info Mike. Isn't there an issue with a one piece shaft hitting the floor or something like that?
    __________________________________________________ ______________________________________
    "Never race anything you can't afford to light on fire and push off a cliff."


    The Mule: '03 sonoma ECSB, 4.3L/auto - E-fans, SLP y-pipe, 3" cat-back, CAI, UD pullies, free mods, A/C delete, XTREME80 tuned, Torsen LSD, UB machine UCAs, Spohn LCAs tall balljoints, coilovers and adjustable shocks, some ZQ8 stuff, ZO6 wheels, envoy'd, race seats, Toyo R888's.

    The Bird: '95 Firebird Formula ram air, LT1/T56.






  5. #5
    Join Date
    Feb 2007
    Location
    Tallahassee
    Age
    38
    Posts
    22,743
    Rep Power
    591483

    Re: One Peice Driveshaft

    IDK. All is I know is that the 2pc shaft has issues
    2003 S-10 ZQ8 - 262/M5 1986 Pontiac Trans Am - 355/A4

  6. #6
    Join Date
    Oct 2004
    Location
    Shawnee, KS
    Age
    33
    Posts
    673
    Rep Power
    4372

    Re: One Peice Driveshaft

    Good find. I'm been looking into getting a CF drive-shaft for over a year now. Still don't know if I should go with a 1 or 2 peice system.
    1996 S10 LS X-Cab 4.3L Auto, FIPK2, TBMod, HPPG3, 160*t-stat, Edelbrock TES headers, Custom Exhaust, ASP Pulleys, E-Fan, MSD 6A, Coil, wires. Belltech 3/4" Drop, Hotchkis Sway-Bars, 17x8 Torque-Thrust 2s.

  7. #7
    Join Date
    Oct 2007
    Location
    TUSCALOOSA, AL
    Age
    35
    Posts
    106
    Rep Power
    93

    Re: One Peice Driveshaft

    SWEET FIND!!! My 2 peice sucks, and it always vibrates at 55-70mph...I even have the JTR driveline spacer kit and it hits the floor pan when I floor it, or gun it on an incline/decline!!! WTF???
    02 GMC SONOMA SLS, ZQ8, EXT. CAB, 4.3L AUTO

    AEM Brute force CAI, 75mm MAF sensor, 50 series flowmaster, no pre-cat., no cat., no o2 sensor, 3 inch pipe w/turndown, t/b spacer, CFM-TECH 75mm t/b, custom comp. tune, FLX-60 e-fan, vette servo, 185 t-stat, MSD 6AL-2, Accel cap and rotor, JBA wires w/boot guards, NGK iridium plugs, MSD coil, march pullies, optima red top, G80 w/3.90 Motive Gears, slotted rotors w/hawk pads, trans. cooler, polly. trans. mount, ZQ8 susp. w/belltech spindles and blocks, all synthetic fluids, billet grille, checkmate bed cover, 18 and 20 inch wheels, SS mirrors, euro tails, flip-up monitor, 15% tint, etc...

  8. #8
    Join Date
    Jun 2006
    Location
    Sackville, NB, Canada
    Age
    37
    Posts
    5,071
    Rep Power
    481068

    Re: One Peice Driveshaft

    Quote Originally Posted by MATTL View Post
    SWEET FIND!!! My 2 peice sucks, and it always vibrates at 55-70mph...I even have the JTR driveline spacer kit and it hits the floor pan when I floor it, or gun it on an incline/decline!!! WTF???
    Have you checked your trans and motor mounts? The stock ones are garbage and even if they aren't broke they could be way too soft. My motor mounts weren't even broken and my engine moved enough to put my fan through the shroud.
    __________________________________________________ ______________________________________
    "Never race anything you can't afford to light on fire and push off a cliff."


    The Mule: '03 sonoma ECSB, 4.3L/auto - E-fans, SLP y-pipe, 3" cat-back, CAI, UD pullies, free mods, A/C delete, XTREME80 tuned, Torsen LSD, UB machine UCAs, Spohn LCAs tall balljoints, coilovers and adjustable shocks, some ZQ8 stuff, ZO6 wheels, envoy'd, race seats, Toyo R888's.

    The Bird: '95 Firebird Formula ram air, LT1/T56.






  9. #9
    Join Date
    Jul 2008
    Location
    SE, WI
    Posts
    2,490
    Rep Power
    100027

    Re: One Peice Driveshaft

    Mine fan only hit in the winter, so I just took the fan off
    2003 auto Long Bed 4.3L ZQ8 + 2/3, Caltracs, rear disk, Auburn LSD, SS mirrors, Snugtop, 16" Zyrgo fan + VSC, 255/50/R16 Falken ZE-512, 2114 with 48LB Racetronix injectors, marine TB, TorqFlo Trans cooler, 2 BAR MAP, Accel 60115 distributor, A1000 FPR, Corbeau Forza seats, Mach headers, 2.5" front mount intercooler, Innovative turbo, Purple 3,000 RPM torque converter, EFILive COS3 tune.

    If this post has offended you in any way, please feel free to leave negative feedback.

  10. #10
    Join Date
    Feb 2007
    Location
    Tallahassee
    Age
    38
    Posts
    22,743
    Rep Power
    591483

    Re: One Peice Driveshaft

    Sounds like a bad tranny mount, bad leaf bushings or weak leaf springs causing pinion movement on the hitting issue MATTL

    ZR1-S10 could also look at DennysDriveshafts for special made units.
    2003 S-10 ZQ8 - 262/M5 1986 Pontiac Trans Am - 355/A4

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •